LearnIR Copy to AnalysIR All

Post Reply
Gromit
Posts: 3
Joined: Thu Nov 10, 2022 3:03 pm

LearnIR Copy to AnalysIR All

Post by Gromit »

I recently bought the Nano Alternative LearnIR device (MCU: 328P : Jun 30 2020 20:17:37). Using LearnIR version 2.0.2.2007 I captured several transmisions from a remote and tried to send them to AnalysIR (v 1.16.100.8083) using the 'All' checkbox and the Channel 1 button to copy them, but it is not working. I removed the check from 'All' and tried to copy the captures one by one and it worked except for 3 lines that refuse to copy. I noticed those 3 lines were decoded as RAW and everything else was RC5 or RC5x.

I captured those lines again and 2 of the 3 are now decoded as RC5 and RC5x, but one of the captures still decodes as RAW and copies, but the data in AnalysIR is not consistent with LearnIR . The capture appears to have a valid format, but always decodes as raw. After relaunching LearnIR and AnalysIR and recapturing the buttons on the remote the copy appears to works sometimes and not other times.

Is it just me or is anyone else having issues copying captures from LearnIR to AnalysIR?

User avatar
AnalysIR
Site Admin
Posts: 752
Joined: Sat Aug 31, 2013 3:51 pm
Location: Dublin, Ireland
Contact:

Re: LearnIR Copy to AnalysIR All

Post by AnalysIR »

First thing to try is to point the remote IR LED directly at the LearnIR receiver from a distance of 1->2m (or 3->6 feet).

Once you get rid of the RAW sinals, we can then look at other issue.

Finally, You can connect the LearnIR directly to the AnalysIR app, to avoid relaying them via the LearnIR APP.

Post Reply