Arduino Leonardo and Serial Issues with Windows Bluetooth

For AnalysIR backers to discuss topics related to the campaign & initial release of AnalysIR. Posting here is for Backers only.
Post Reply
User avatar
AnalysIR
Site Admin
Posts: 524
Joined: Sat Aug 31, 2013 3:51 pm
Location: Dublin, Ireland
Contact:

Arduino Leonardo and Serial Issues with Windows Bluetooth

Post by AnalysIR » Mon Sep 16, 2013 8:29 pm

This describes some general issues with Arduino, Leonardo & serial.

We recently, came across an issue on one of our Windows PCs with blutetooth installed. We remembered reading previously that the Arduino IDE doesnt react well with serial over bluetooth when it is installed on the same system.The symptoms include long delays when clicking on the Tools menu of the IDE. Everything works as long as you are happy to wait every time you access this menu.

However, when the Leonardo is added to the mix we found that there seemed to be a conflict between the Bluetooth COM ports and the Leonardo as it was going through its boot/upload sequence. Bottom line is that it wasn't possible to upload firmware to the Leonardo in this configuration. The workaroud was to disbable all bluetooth on the PC, which required a restart.

Afterwards everything worked fine and as expected.

We will await a future fix for the Arduino IDE.

Hope this helps.

Note: remember to set the definition to true for Leonardo and false for all others when compiling the AnalysIR code on the IDE for the Leonardo platform.

Post Reply